Nc30 electrical issues

Forum rules
Please can you post items for sale or wanted in the correct For Sale section. Items / bikes for sale here will be removed without warning. Reasons for this are in the FAQ. Thanks
addyhawth
Settled in member
Reactions:
Posts: 9
Joined: Mon Jul 15, 2019 9:33 am
Re: Nc30 electrical issues

Post by addyhawth » Wed Jan 15, 2020 12:37 pm

Ok so you where correct with the project I was gave a new reproduction switch gear but had the oem one that had seen better days, I’ve switched this over and can confirm that this was the issue with this end.

However The starter switch is still dead,

Neutral wire is connected, and I don’t have a neutral light, Bike is in neutral (rear wheel freely spins)

I’m guessing the clutch wires at lever weren’t wired correctly On repo switch gear so I’ll go back and make sure to reconfigure the plugs to match loom,

I also haven’t or can’t see any wires that would attached to side stand.. I’m guessing this could also be issue

magg
Senior Member
Reactions:
Posts: 1780
Joined: Mon Sep 20, 2010 11:55 pm
Bike owned: VFR400
Location: Blue Mountain NSW Australia
Re: Nc30 electrical issues

Post by magg » Wed Jan 15, 2020 9:39 pm

If you wish to use the new switch just repin the connectors for the correct configuration or try another replacement. No side stand switch on NC30. No neutral light when in neutral suggests either a dud bulb or dud switch. A dud or missing diode will make the neutral switch ineffective. The two wires to the clutch switch can simply be linked together and the start button should function, make sure the bike is in neutral.

addyhawth
Settled in member
Reactions:
Posts: 9
Joined: Mon Jul 15, 2019 9:33 am
Re: Nc30 electrical issues

Post by addyhawth » Wed Jan 15, 2020 11:30 pm

Managed to sort it Magg!

I’ve learned a lot, and the feeling of accomplishment is something else!!!

Thanks for your input! It’s greatly appreciated


Post Reply