Wiring RVF400

New members may care to make their first post here to introduce themselves. show us your bike, where you live etc etc. its also polite to get the drinks in too.
Post Reply
Bazza400
One Hit Wonder
Reactions:
Posts: 1
Joined: Thu Jan 31, 2019 3:14 pm
Wiring RVF400

Post by Bazza400 » Fri Feb 01, 2019 12:45 am

Hi thanks for the opportunity to join the site.
I am an ozzie living in china so any help would be much appreciated. Difficult to find info on things if you get my drift.
Well i have a rvf400 i am rebuilding and ran into a small hitch. This is the third bike i have rebuilt. First was a NSR250 SP the second was a vfr400 which led me to the RVF400 because i was so impressed with the engine and the haneling of the VFR400.

When i checked the charging system i noticed the battery wasnt charging. So i replaced the rectifier and noticed it still wasnt charging. So i disconected the alternator 3pin plug to find it was so corroded and burnt. I then replaced the 3pin plug with a new one, i then checked the alternator side of the connection and got about 47 to 50 volts ac from each terminal with no earth leakage. 
So i was good there i thought so proceeded to check the charging system again but still wasnt charging. This time i replaced the battery thinking this has got to be it, but still isnt charging. Then i went and had a rest and did alot of head scratching trying to figure out what the hell was wrong. I went back and tried to start the bike againg and this time she wouldn't start not even a kick like the battery was dead flat or not connected. I checked the fuse box and found the fuse had blown. I then checked the starter solenoid and the connection was toast. 
So i changed the starter solenoid with a new one and it started but my concern is the starter solenoid has one really hot wire and without a wiring diagram i cant check what the previous owner did if anything. 

Can somebody please help because i dont think i am going to have any hair left by the weekend. Not that i had much to start with. I think its got something to do with the rectifier . Any help woul be much appreciated. 

Cheers Bazza in china.

User avatar
JZH
Site Supporter
Site Supporter
Reactions:
Posts: 368
Joined: Mon Oct 27, 2008 7:02 pm
Bike owned: RSCBRRVFVFRST
Location: London, UK/So.Cal., USA
Contact:
Re: Wiring RVF400

Post by JZH » Sat Feb 02, 2019 4:24 pm

I hate diagnosing electrical problems remotely, but the first step is to follow "the drill", which you can find on the VFRD forum.

The RVF's electrical system isn't very complicated, but the OEM configuration does have too many connectors, which are not environmentally sealed and can corrode. The OEM reg/recs are also quite weak, but the aftermarket replacements are as well. What works, assuming you actually need a new reg/rec, is a used MOSFET or series-type reg/rec as found on later model bikes like R1s and GSX-Rs. It's the old-style OEM reg/recs that are the problem; the more modern ones seem to be fine.

Ciao,

JZH
JZH

London, UK/So.Cal., USA
www.vsource.org

dazzx10r
Settled in member
Reactions:
Posts: 5
Joined: Mon Jan 28, 2019 4:04 pm
Re: Wiring RVF400

Post by dazzx10r » Mon Feb 04, 2019 8:20 am

VFR400 diagram here, not sure if its the same? https://photobucket.com/gallery/user/hm ... OQ==/?ref=

davlr
Settled in member
Reactions:
Posts: 155
Joined: Mon Jan 17, 2011 3:03 pm
Bike owned: NC30 35 23 APRILIA RS!
Re: Wiring RVF400

Post by davlr » Tue Feb 05, 2019 8:38 am

Rvf wiring diagram is in the documents section on the front page of the site and it is different to the VFR.
Also welcome to the forum


Post Reply

Return to “New Members Introductions”