Page 1 of 1

XJR400 restricted?

Posted: Mon Aug 10, 2015 4:02 am
by quaterchicken
I've noticed that my 4HM will rev freely past 9K rpms in lower gears, but when in 5th or 6th gear the ignition seem to cut out at ~7K to ~8K rpms.

I'm just wondering if the after market derestricted CDIs for sale on ebay / aliexpress can resolve this problem?

Re: XJR400 restricted?

Posted: Mon Aug 10, 2015 1:21 pm
by Evilchicken0
The Japanese restriction is a speed restriction that comes in at 180kmh or 112 mph ... I don't think your bike will be hitting that speed in 5th, probably not even in 6th until the very top revs.

It could be somebody tried a home derestriction, very few of which seem to work. The FZR CDI will restrict to 12.5k rpm in all gears if the restriction is tampered with. The CDI has to get a Zero signal from the speedo (there are wire in the back of it) so have a look and see if there's a spare block connector up there. The derestricted (race) CDI's for the FZR 3TJ take away the side stand switch and fuel reserve (electronic on the 3TJ) so they're not best for road use.
There was a FZR derestriction M-Max box on the bay ... check the thread in the FZR area.

I don't think it's the restriction though.

Re: XJR400 restricted?

Posted: Tue Aug 11, 2015 1:17 am
by quaterchicken
Thanks for the info, it did seem strange that power loss appear to be occurring at different rpms for different gears. Maybe its a fueling issue... the bike is getting serviced soon so will get some professional analysis :rocks:

Re: XJR400 restricted?

Posted: Tue Aug 11, 2015 9:21 am
by Evilchicken0
Could be fuel - although you'd expect it to be in all gears. Does this happen after a certain time on the bike, that could be a fuel filter if you have one.

Re: XJR400 restricted?

Posted: Wed Aug 12, 2015 10:07 am
by quaterchicken
I do have an inline fuel filter, however this problem have existed prior to the filter installation. I ride like a granny, rarely reaching over 8K rpms, so this problem hasn't been too much of a pain.

Re: XJR400 restricted?

Posted: Wed Aug 12, 2015 1:10 pm
by Evilchicken0
Filter installation ? If you put a filter where there wasn't one it could be restricting the fuel flow so at high revs the bike would feel like it's partly running out of fuel. It would probably run ok lower down.
My Bimota will do this if the fuel hoses are routed badly 90% of the time its ok but run it at high rpm for a while and it will eventually loose a bit of power, then once you slow down for a while it's fine (high rpm equates to 120mph + in top).
Clean the inside of the fuel tank, the gauze filter above the fuel tap, and remove the fuel filter. Check the fuel hose is the right diameter, look along the hose to see if there's any creases where a kink might be.

Re: XJR400 restricted?

Posted: Sat Sep 12, 2015 6:50 am
by quaterchicken
Mystery solved, the air intake trumpet was missing the entire time. Managed to get a spare one, now the bike has no problem reving at high rpms. :up:

Re: XJR400 restricted?

Posted: Sun Sep 13, 2015 7:40 am
by Evilchicken0
Cool !!!

Re: XJR400 restricted?

Posted: Sun Mar 31, 2019 8:17 pm
by richhemmings
Glad OP found solution - I had a similar issue on my recently purchased XJR400.
Sweet until 8-9k in 3rd/4th (about 60mph).
Found a simple air filter sorted it (pretty sure the one I replaced was the factory fitted 20+ years ago - ffs).

HTH someone.